The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / luajit / Config.in
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/luajit/Config.in b/cirros-testvm/src-cirros/buildroot-2015.05/package/luajit/Config.in
new file mode 100644 (file)
index 0000000..f6995e2
--- /dev/null
@@ -0,0 +1,34 @@
+config BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS
+       bool
+       default y if BR2_i386 || \
+               (BR2_x86_64 && BR2_HOSTARCH='x86_64') || \
+               BR2_powerpc || BR2_arm || BR2_armeb || \
+               ((BR2_mips || BR2_mipsel) && !BR2_MIPS_SOFT_FLOAT)
+
+config BR2_PACKAGE_LUAJIT
+       bool "luajit"
+       select BR2_PACKAGE_HAS_LUAINTERPRETER
+       # Luajit is only available for some target architectures, and
+       # has some complexity wrt 32/64. See luajit.mk for details.
+       depends on BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS
+       # luajit.mk uses the "-m32" compiler option to build 32bit
+       # binaries, so check if that option is supported. See
+       # luajit.mk for details.
+       select BR2_HOSTARCH_NEEDS_IA32_COMPILER if !BR2_ARCH_IS_64
+       help
+         LuaJIT implements the full set of language features defined
+         by Lua 5.1. The virtual machine (VM) is API- and
+         ABI-compatible to the standard Lua interpreter and can be
+         deployed as a drop-in replacement.
+
+         http://luajit.org/
+
+if BR2_PACKAGE_LUAJIT
+
+config BR2_PACKAGE_PROVIDES_LUAINTERPRETER
+       default "luajit"
+
+config BR2_PACKAGE_LUAINTERPRETER_ABI_VERSION
+       default "5.1"
+
+endif