The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / log4cxx / log4cxx.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/log4cxx/log4cxx.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/log4cxx/log4cxx.mk
new file mode 100644 (file)
index 0000000..7d7e2e9
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# log4cxx
+#
+################################################################################
+
+LOG4CXX_VERSION = 0.10.0
+LOG4CXX_SITE = http://archive.apache.org/dist/logging/log4cxx/$(LOG4CXX_VERSION)
+LOG4CXX_SOURCE = apache-log4cxx-$(LOG4CXX_VERSION).tar.gz
+LOG4CXX_INSTALL_STAGING = YES
+LOG4CXX_LICENSE = Apache-2.0
+LOG4CXX_LICENSE_FILES = LICENSE
+
+LOG4CXX_CONF_OPTS = \
+       --with-apr=$(STAGING_DIR)/usr/bin/apr-1-config \
+       --with-apr-util=$(STAGING_DIR)/usr/bin/apu-1-config \
+       --disable-dot \
+       --disable-doxygen \
+       --disable-html-docs
+
+LOG4CXX_DEPENDENCIES = apr apr-util
+
+$(eval $(autotools-package))