The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / linphone / linphone.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/linphone/linphone.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/linphone/linphone.mk
new file mode 100644 (file)
index 0000000..e0d4fa3
--- /dev/null
@@ -0,0 +1,33 @@
+################################################################################
+#
+# linphone
+#
+################################################################################
+
+LINPHONE_VERSION_MAJOR = 3.6
+LINPHONE_VERSION = $(LINPHONE_VERSION_MAJOR).1
+LINPHONE_SITE = http://download-mirror.savannah.gnu.org/releases/linphone/$(LINPHONE_VERSION_MAJOR).x/sources
+LINPHONE_CONF_OPTS = \
+       --enable-external-ortp \
+       --enable-external-mediastreamer \
+       --disable-strict
+# configure is out of sync causing deplibs linking issues
+LINPHONE_AUTORECONF = YES
+LINPHONE_INSTALL_STAGING = YES
+LINPHONE_DEPENDENCIES = host-pkgconf ortp mediastreamer libeXosip2 speex
+LINPHONE_LICENSE = GPLv2+
+LINPHONE_LICENSE_FILES = COPYING
+
+ifeq ($(BR2_arc),y)
+# toolchain __arc__ define conflicts with libosip2 source
+LINPHONE_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -U__arc__"
+endif
+
+ifeq ($(BR2_PACKAGE_LIBGTK2)$(BR2_PACKAGE_XORG7),yy)
+LINPHONE_CONF_OPTS += --enable-gtk_ui
+LINPHONE_DEPENDENCIES += libgtk2
+else
+LINPHONE_CONF_OPTS += --disable-gtk_ui
+endif
+
+$(eval $(autotools-package))