The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / linknx / linknx.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/linknx/linknx.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/linknx/linknx.mk
new file mode 100644 (file)
index 0000000..7ecd947
--- /dev/null
@@ -0,0 +1,34 @@
+################################################################################
+#
+# linknx
+#
+################################################################################
+
+LINKNX_VERSION = 0.0.1.32
+LINKNX_SITE = http://downloads.sourceforge.net/project/linknx/linknx/linknx-$(LINKNX_VERSION)
+LINKNX_LICENSE = GPLv2+
+LINKNX_INSTALL_STAGING = YES
+LINKNX_CONF_OPTS = \
+       --without-lua \
+       --without-log4cpp \
+       --without-pth-test \
+       --with-pth=$(STAGING_DIR)/usr \
+       --disable-smtp
+
+LINKNX_DEPENDENCIES = libpthsem $(if $(BR2_PACKAGE_ARGP_STANDALONE),argp-standalone)
+
+ifeq ($(BR2_PACKAGE_MYSQL),y)
+LINKNX_CONF_OPTS += --with-mysql=$(STAGING_DIR)/usr/bin/mysql_config
+LINKNX_DEPENDENCIES += mysql
+else
+LINKNX_CONF_OPTS += --without-mysql
+endif
+
+ifeq ($(BR2_PACKAGE_LIBCURL),y)
+LINKNX_CONF_OPTS += --with-libcurl=$(STAGING_DIR)/usr/bin/curl-config
+LINKNX_DEPENDENCIES += libcurl
+else
+LINKNX_CONF_OPTS += --without-libcurl
+endif
+
+$(eval $(autotools-package))