The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libxslt / libxslt.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libxslt/libxslt.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libxslt/libxslt.mk
new file mode 100644 (file)
index 0000000..2e5cc14
--- /dev/null
@@ -0,0 +1,34 @@
+################################################################################
+#
+# libxslt
+#
+################################################################################
+
+LIBXSLT_VERSION = 1.1.28
+LIBXSLT_SITE = ftp://xmlsoft.org/libxslt
+LIBXSLT_INSTALL_STAGING = YES
+LIBXSLT_LICENSE = MIT
+LIBXSLT_LICENSE_FILES = COPYING
+
+LIBXSLT_CONF_OPTS = \
+       --with-gnu-ld \
+       --without-debug \
+       --without-python \
+       --with-libxml-prefix=$(STAGING_DIR)/usr/
+LIBXSLT_CONFIG_SCRIPTS = xslt-config
+LIBXSLT_DEPENDENCIES = libxml2
+
+# If we have enabled libgcrypt then use it, else disable crypto support.
+ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
+LIBXSLT_DEPENDENCIES += libgcrypt
+LIBXSLT_CONF_ENV += LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-config
+else
+LIBXSLT_CONF_OPTS += --without-crypto
+endif
+
+HOST_LIBXSLT_CONF_OPTS = --without-debug --without-python --without-crypto
+
+HOST_LIBXSLT_DEPENDENCIES = host-libxml2
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))