The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libxmlrpc / 0002-fix-non-cplusplus-build.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libxmlrpc/0002-fix-non-cplusplus-build.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/libxmlrpc/0002-fix-non-cplusplus-build.patch
new file mode 100644 (file)
index 0000000..efeb9cc
--- /dev/null
@@ -0,0 +1,27 @@
+Handle builds without C++
+
+libxmlrpc nicely handles the fact of being built without C++ support,
+except for one location, fixed by this patch.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/lib/util/Makefile
+===================================================================
+--- a/lib/util/Makefile
++++ b/lib/util/Makefile
+@@ -41,11 +41,14 @@
+ LIBOBJS = \
+   casprintf.o \
+   cmdline_parser.o \
+-  cmdline_parser_cpp.o \
+   getoptx.o \
+   string_parser.o \
+   stripcaseeq.o \
++ifeq ($(ENABLE_CPLUSPLUS),yes)
++LIBOBJS += cmdline_parser_cpp.o
++endif
++
+ .PHONY: all
+ all: $(LIBOBJS)