The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libxmlrpc / 0001-fix-gennmtab-build.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libxmlrpc/0001-fix-gennmtab-build.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/libxmlrpc/0001-fix-gennmtab-build.patch
new file mode 100644 (file)
index 0000000..8cdd932
--- /dev/null
@@ -0,0 +1,25 @@
+Fix build of host tool
+
+genmtab is a tool that needs to be built for the host as it is used
+during the compilation process of libxmlrpc. Its Makefile needs a bit
+of tuning to use the conventional CC_FOR_BUILD, CFLAGS_FOR_BUILD and
+LDFLAGS_FOR_BUILD variables.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/lib/expat/gennmtab/Makefile
+===================================================================
+--- a/lib/expat/gennmtab/Makefile
++++ b/lib/expat/gennmtab/Makefile
+@@ -40,9 +40,9 @@
+ dep: dep-common
+ gennmtab.o:%.o:%.c
+-      $(BUILDTOOL_CC) -c $< -o $@ $(CFLAGS_ALL) $(INCLUDES)
++      $(CC_FOR_BUILD) -c $< -o $@ $(CFLAGS_FOR_BUILD) $(INCLUDES)
+ gennmtab:%:%.o
+-      $(BUILDTOOL_CCLD) -o $@ $(LDFLAGS) $^
++      $(CC_FOR_BUILD) -o $@ $(LDFLAGS_FOR_BUILD) $^
+ include depend.mk