The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libunistring / libunistring.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libunistring/libunistring.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libunistring/libunistring.mk
new file mode 100644 (file)
index 0000000..0060518
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# libunistring
+#
+################################################################################
+
+LIBUNISTRING_VERSION = 0.9.5
+LIBUNISTRING_SITE = $(BR2_GNU_MIRROR)/libunistring
+LIBUNISTRING_SOURCE = libunistring-$(LIBUNISTRING_VERSION).tar.xz
+LIBUNISTRING_INSTALL_STAGING = YES
+LIBUNISTRING_LICENSE = LGPLv3+
+LIBUNISTRING_LICENSE_FILES = COPYING.LIB
+
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
+LIBUNISTRING_CONF_OPTS += --enable-threads=posix
+else
+LIBUNISTRING_CONF_OPTS += --disable-threads
+endif
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))