The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libtpl / libtpl.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libtpl/libtpl.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libtpl/libtpl.mk
new file mode 100644 (file)
index 0000000..ed3bfb5
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# libtpl
+#
+################################################################################
+
+LIBTPL_VERSION = v1.6.1
+LIBTPL_SITE = $(call github,troydhanson,tpl,$(LIBTPL_VERSION))
+LIBTPL_INSTALL_STAGING = YES
+LIBTPL_LICENSE = BSD-like
+LIBTPL_LICENSE_FILES = LICENSE
+
+LIBTPL_AUTORECONF = YES
+
+define LIBTPL_CREATE_MISSING_FILES
+       touch $(@D)/NEWS $(@D)/AUTHORS $(@D)/ChangeLog $(@D)/COPYING
+endef
+LIBTPL_POST_EXTRACT_HOOKS += LIBTPL_CREATE_MISSING_FILES
+
+$(eval $(autotools-package))