The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libsvg / libsvg.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libsvg/libsvg.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libsvg/libsvg.mk
new file mode 100644 (file)
index 0000000..a876c4e
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# libsvg
+#
+################################################################################
+
+LIBSVG_VERSION = 0.1.4
+LIBSVG_SITE = http://cairographics.org/snapshots
+LIBSVG_DEPENDENCIES = host-pkgconf libpng libjpeg
+LIBSVG_INSTALL_STAGING = YES
+LIBSVG_LICENSE = LGPLv2+
+LIBSVG_LICENSE_FILES = COPYING
+
+# libsvg needs at last a XML parser
+ifeq ($(BR2_PACKAGE_EXPAT),y)
+LIBSVG_CONF_OPTS += --with-expat
+LIBSVG_DEPENDENCIES += expat
+else
+LIBSVG_CONF_OPTS += --with-libxml2
+LIBSVG_DEPENDENCIES += libxml2
+endif
+
+$(eval $(autotools-package))