The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libstrophe / libstrophe.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libstrophe/libstrophe.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libstrophe/libstrophe.mk
new file mode 100644 (file)
index 0000000..8493692
--- /dev/null
@@ -0,0 +1,25 @@
+################################################################################
+#
+# libstrophe
+#
+################################################################################
+
+LIBSTROPHE_VERSION = 0.8.6
+LIBSTROPHE_SITE = $(call github,strophe,libstrophe,$(LIBSTROPHE_VERSION))
+LIBSTROPHE_DEPENDENCIES = openssl host-pkgconf
+LIBSTROPHE_AUTORECONF = YES
+LIBSTROPHE_LICENSE = MIT or GPLv3
+LIBSTROPHE_LICENSE_FILES = MIT-LICENSE.txt GPL-LICENSE.txt
+LIBSTROPHE_INSTALL_STAGING = YES
+
+ifeq ($(BR2_PACKAGE_EXPAT),y)
+# Passing --without-libxml2 doesn't work, due to how AC_ARG_WITH is
+# used in configure.ac. As long as --with-libxml2 is *not* passed, the
+# configure script assumes expat should be used.
+LIBSTROPHE_DEPENDENCIES += expat
+else
+LIBSTROPHE_CONF_OPTS += --with-libxml2
+LIBSTROPHE_DEPENDENCIES += libxml2
+endif
+
+$(eval $(autotools-package))