The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libssh2 / libssh2.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libssh2/libssh2.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libssh2/libssh2.mk
new file mode 100644 (file)
index 0000000..3b4df37
--- /dev/null
@@ -0,0 +1,40 @@
+################################################################################
+#
+# libssh2
+#
+################################################################################
+
+LIBSSH2_VERSION = 1.5.0
+LIBSSH2_SITE = http://www.libssh2.org/download
+LIBSSH2_LICENSE = BSD
+LIBSSH2_LICENSE_FILES = COPYING
+LIBSSH2_INSTALL_STAGING = YES
+LIBSSH2_CONF_OPTS = --disable-examples-build
+
+# libssh2 must use either libgcrypt or OpenSSL
+# Only select openssl if libgcrypt is not selected
+ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
+LIBSSH2_DEPENDENCIES += libgcrypt
+LIBSSH2_CONF_OPTS += --with-libgcrypt \
+       --with-libgcrypt-prefix=$(STAGING_DIR)/usr \
+       --without-openssl
+# configure.ac forgets to link to dependent libraries of gcrypt breaking static
+# linking
+LIBSSH2_CONF_ENV += LIBS="$(shell $(STAGING_DIR)/usr/bin/libgcrypt-config --libs)"
+else
+LIBSSH2_DEPENDENCIES += openssl
+LIBSSH2_CONF_OPTS += --with-openssl \
+       --with-libssl-prefix=$(STAGING_DIR)/usr \
+       --without-libgcrypt
+endif
+
+# Add zlib support if enabled
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+LIBSSH2_DEPENDENCIES += zlib
+LIBSSH2_CONF_OPTS += --with-libz \
+       --with-libz-prefix=$(STAGING_DIR)/usr
+else
+LIBSSH2_CONF_OPTS += --without-libz
+endif
+
+$(eval $(autotools-package))