The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libsrtp / libsrtp.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libsrtp/libsrtp.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libsrtp/libsrtp.mk
new file mode 100644 (file)
index 0000000..bcf344f
--- /dev/null
@@ -0,0 +1,35 @@
+################################################################################
+#
+# libsrtp
+#
+################################################################################
+
+LIBSRTP_VERSION = v1.5.2
+LIBSRTP_SITE = $(call github,cisco,libsrtp,$(LIBSRTP_VERSION))
+LIBSRTP_INSTALL_STAGING = YES
+LIBSRTP_LICENSE = BSD-3c
+LIBSRTP_LICENSE_FILES = LICENSE
+
+ifeq ($(BR2_STATIC_LIBS),y)
+LIBSRTP_MAKE_OPTS = libsrtp.a
+else ifeq ($(BR2_SHARED_LIBS),y)
+LIBSRTP_MAKE_OPTS = shared_library
+else
+LIBSRTP_MAKE_OPTS = libsrtp.a shared_library
+endif
+
+# While libsrtp is not using pkg-config itself, it checks if
+# pkg-config is available to determine whether it should install
+# libsrtp.pc. Since installing it seems useful, let's depend on
+# host-pkgconf to make sure pkg-config is installed.
+LIBSRTP_DEPENDENCIES = host-pkgconf
+
+# openssl handling needs libdl support
+ifeq ($(BR2_PACKAGE_OPENSSL)x$(BR2_STATIC_LIBS),yx)
+LIBSRTP_DEPENDENCIES += openssl
+LIBSRTP_CONF_OPTS += --enable-openssl
+else
+LIBSRTP_CONF_OPTS += --disable-openssl
+endif
+
+$(eval $(autotools-package))