The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libsoup / libsoup.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libsoup/libsoup.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libsoup/libsoup.mk
new file mode 100644 (file)
index 0000000..8cbd0cb
--- /dev/null
@@ -0,0 +1,31 @@
+################################################################################
+#
+# libsoup
+#
+################################################################################
+
+LIBSOUP_VERSION_MAJOR = 2.48
+LIBSOUP_VERSION = $(LIBSOUP_VERSION_MAJOR).0
+LIBSOUP_SOURCE = libsoup-$(LIBSOUP_VERSION).tar.xz
+LIBSOUP_SITE = http://ftp.gnome.org/pub/gnome/sources/libsoup/$(LIBSOUP_VERSION_MAJOR)
+LIBSOUP_LICENSE = LGPLv2+
+LIBSOUP_LICENSE_FILES = COPYING
+LIBSOUP_INSTALL_STAGING = YES
+LIBSOUP_CONF_ENV = ac_cv_path_GLIB_GENMARSHAL=$(LIBGLIB2_HOST_BINARY)
+LIBSOUP_CONF_OPTS = --disable-glibtest
+LIBSOUP_DEPENDENCIES = host-pkgconf host-libglib2 \
+       libglib2 libxml2 sqlite host-intltool
+
+ifeq ($(BR2_PACKAGE_LIBSOUP_GNOME),y)
+LIBSOUP_CONF_OPTS += --with-gnome
+else
+LIBSOUP_CONF_OPTS += --without-gnome
+endif
+
+ifeq ($(BR2_PACKAGE_LIBSOUP_SSL),y)
+LIBSOUP_DEPENDENCIES += glib-networking
+else
+LIBSOUP_CONF_OPTS += --disable-tls-check
+endif
+
+$(eval $(autotools-package))