The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libsigc / libsigc.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libsigc/libsigc.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libsigc/libsigc.mk
new file mode 100644 (file)
index 0000000..7c127c4
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# libsigc
+#
+################################################################################
+
+LIBSIGC_VERSION_MAJOR = 2.2
+LIBSIGC_VERSION = $(LIBSIGC_VERSION_MAJOR).11
+LIBSIGC_SOURCE = libsigc++-$(LIBSIGC_VERSION).tar.xz
+LIBSIGC_SITE = http://ftp.gnome.org/pub/GNOME/sources/libsigc++/$(LIBSIGC_VERSION_MAJOR)
+LIBSIGC_DEPENDENCIES = host-m4
+LIBSIGC_INSTALL_STAGING = YES
+LIBSIGC_LICENSE = LGPLv2.1+
+LIBSIGC_LICENSE_FILES = COPYING
+
+define LIBSIGC_INSTALL_TARGET_FIXUP
+       rm -rf $(TARGET_DIR)/usr/share/devhelp/books/libsigc++*
+endef
+
+LIBSIGC_POST_INSTALL_TARGET_HOOKS += LIBSIGC_INSTALL_TARGET_FIXUP
+
+$(eval $(autotools-package))