The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libshout / libshout.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libshout/libshout.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libshout/libshout.mk
new file mode 100644 (file)
index 0000000..faee3eb
--- /dev/null
@@ -0,0 +1,28 @@
+################################################################################
+#
+# libshout
+#
+################################################################################
+
+LIBSHOUT_VERSION = 2.3.1
+LIBSHOUT_SITE = http://downloads.xiph.org/releases/libshout
+LIBSHOUT_LICENSE = LGPLv2+
+LIBSHOUT_LICENSE_FILES = COPYING
+LIBSHOUT_INSTALL_STAGING = YES
+LIBSHOUT_DEPENDENCIES = host-pkgconf libogg libvorbis
+
+ifeq ($(BR2_PACKAGE_LIBTHEORA),y)
+LIBSHOUT_CONF_OPTS += --enable-theora
+LIBSHOUT_DEPENDENCIES += libtheora
+else
+LIBSHOUT_CONF_OPTS += --disable-theora
+endif
+
+ifeq ($(BR2_PACKAGE_SPEEX),y)
+LIBSHOUT_CONF_OPTS += --enable-speex
+LIBSHOUT_DEPENDENCIES += speex
+else
+LIBSHOUT_CONF_OPTS += --disable-speex
+endif
+
+$(eval $(autotools-package))