The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libserialport / libserialport.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libserialport/libserialport.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libserialport/libserialport.mk
new file mode 100644 (file)
index 0000000..2e57653
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# libserialport
+#
+################################################################################
+
+LIBSERIALPORT_VERSION = e31f2c6b8b8f2b7e554df911cc9a3482b99632b4
+# No https access on upstream git
+LIBSERIALPORT_SITE = git://sigrok.org/libserialport
+LIBSERIALPORT_LICENSE = LGPLv3+
+LIBSERIALPORT_LICENSE_FILES = COPYING
+# Git checkout has no configure script
+LIBSERIALPORT_AUTORECONF = YES
+LIBSERIALPORT_INSTALL_STAGING = YES
+LIBSERIALPORT_DEPENDENCIES = host-pkgconf
+
+define LIBSERIALPORT_ADD_MISSING
+       mkdir -p $(@D)/autostuff
+endef
+
+LIBSERIALPORT_PRE_CONFIGURE_HOOKS += LIBSERIALPORT_ADD_MISSING
+
+$(eval $(autotools-package))