The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libsecret / libsecret.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libsecret/libsecret.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libsecret/libsecret.mk
new file mode 100644 (file)
index 0000000..5a230ae
--- /dev/null
@@ -0,0 +1,24 @@
+################################################################################
+#
+# libsecret
+#
+################################################################################
+
+LIBSECRET_VERSION = 0.18
+LIBSECRET_SITE = http://ftp.gnome.org/pub/GNOME/sources/libsecret/$(LIBSECRET_VERSION)
+LIBSECRET_SOURCE = libsecret-$(LIBSECRET_VERSION).tar.xz
+LIBSECRET_INSTALL_STAGING = YES
+LIBSECRET_DEPENDENCIES = libglib2 host-intltool
+LIBSECRET_CONF_OPTS = --disable-manpages --disable-strict --disable-coverage --enable-vala=no
+LIBSECRET_LICENSE = LGPLv2.1+
+LIBSECRET_LICENSE_FILES = COPYING
+
+ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
+LIBSECRET_DEPENDENCIES += libgcrypt
+LIBSECRET_CONF_OPTS += --enable-gcrypt \
+       --with-libgcrypt-prefix=$(STAGING_DIR)/usr
+else
+LIBSECRET_CONF_OPTS += --disable-gcrypt
+endif
+
+$(eval $(autotools-package))