The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / librsvg / librsvg.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/librsvg/librsvg.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/librsvg/librsvg.mk
new file mode 100644 (file)
index 0000000..5c385dc
--- /dev/null
@@ -0,0 +1,24 @@
+################################################################################
+#
+# librsvg
+#
+################################################################################
+
+LIBRSVG_VERSION_MAJOR = 2.26
+LIBRSVG_VERSION = $(LIBRSVG_VERSION_MAJOR).3
+LIBRSVG_SITE = http://ftp.gnome.org/pub/GNOME/sources/librsvg/$(LIBRSVG_VERSION_MAJOR)
+LIBRSVG_INSTALL_STAGING = YES
+LIBRSVG_CONF_OPTS = --disable-tools
+LIBRSVG_DEPENDENCIES = libxml2 cairo pango libglib2 gdk-pixbuf
+HOST_LIBRSVG_DEPENDENCIES = host-libxml2 host-cairo host-pango host-libglib2 host-gdk-pixbuf
+LIBRSVG_LICENSE = LGPLv2+
+LIBRSVG_LICENSE_FILES = COPYING.LIB
+
+# If we have Gtk2, let's build it first to benefit from librsvg Gtk
+# support.
+ifeq ($(BR2_PACKAGE_LIBGTK2),y)
+LIBRSVG_DEPENDENCIES += libgtk2
+endif
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))