The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libqrencode / libqrencode.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libqrencode/libqrencode.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libqrencode/libqrencode.mk
new file mode 100644 (file)
index 0000000..5f30e77
--- /dev/null
@@ -0,0 +1,28 @@
+################################################################################
+#
+# libqrencode
+#
+################################################################################
+
+LIBQRENCODE_VERSION = 3.4.2
+LIBQRENCODE_SOURCE = qrencode-$(LIBQRENCODE_VERSION).tar.gz
+LIBQRENCODE_SITE = http://fukuchi.org/works/qrencode
+LIBQRENCODE_DEPENDENCIES = host-pkgconf
+LIBQRENCODE_INSTALL_STAGING = YES
+LIBQRENCODE_LICENSE = LGPLv2.1+
+LIBQRENCODE_LICENSE_FILES = COPYING
+
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
+LIBQRENCODE_CONF_ENV += LIBS='-pthread'
+else
+LIBQRENCODE_CONF_OPTS += --disable-thread-safety
+endif
+
+ifeq ($(BR2_PACKAGE_LIBQRENCODE_TOOLS),y)
+LIBQRENCODE_CONF_OPTS += --with-tools=yes
+LIBQRENCODE_DEPENDENCIES += libpng
+else
+LIBQRENCODE_CONF_OPTS += --with-tools=no
+endif
+
+$(eval $(autotools-package))