The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libpng / libpng.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libpng/libpng.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libpng/libpng.mk
new file mode 100644 (file)
index 0000000..2f53a95
--- /dev/null
@@ -0,0 +1,19 @@
+################################################################################
+#
+# libpng
+#
+################################################################################
+
+LIBPNG_VERSION = 1.6.16
+LIBPNG_SERIES = 16
+LIBPNG_SOURCE = libpng-$(LIBPNG_VERSION).tar.xz
+LIBPNG_SITE = http://downloads.sourceforge.net/project/libpng/libpng${LIBPNG_SERIES}/$(LIBPNG_VERSION)
+LIBPNG_LICENSE = libpng license
+LIBPNG_LICENSE_FILES = LICENSE
+LIBPNG_INSTALL_STAGING = YES
+LIBPNG_DEPENDENCIES = host-pkgconf zlib
+LIBPNG_CONFIG_SCRIPTS = libpng$(LIBPNG_SERIES)-config libpng-config
+LIBPNG_CONF_OPTS = $(if $(BR2_ARM_CPU_HAS_NEON),--enable-arm-neon=yes,--enable-arm-neon=no)
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))