The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libplayer / 0001-add-fpic.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libplayer/0001-add-fpic.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/libplayer/0001-add-fpic.patch
new file mode 100644 (file)
index 0000000..e4b227f
--- /dev/null
@@ -0,0 +1,18 @@
+Add -fPIC to CFLAGS
+
+-fPIC is needed to build shared library code.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/src/Makefile
+===================================================================
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -9,6 +9,7 @@
+ SHARED_LIBNAME_VERSION = $(SHARED_LIBNAME).$(VERSION)
+ SHARED_LIBNAME_MAJOR = $(SHARED_LIBNAME).$(shell echo $(VERSION) | cut -f1 -d.)
+ SHARED_LIBNAME_FLAGS = -shared -Wl,-soname,$(SHARED_LIBNAME_MAJOR)
++CFLAGS = -fPIC
+ ifeq ($(BUILD_STATIC),yes)
+   BUILD_RULES += lib_static