The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libosip2 / libosip2.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libosip2/libosip2.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libosip2/libosip2.mk
new file mode 100644 (file)
index 0000000..f22dcc3
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# libosip2
+#
+################################################################################
+
+LIBOSIP2_VERSION = 3.6.0
+LIBOSIP2_SITE = $(BR2_GNU_MIRROR)/osip
+LIBOSIP2_INSTALL_STAGING = YES
+LIBOSIP2_LICENSE = LGPLv2.1+
+LIBOSIP2_LICENSE_FILES = COPYING
+
+ifeq ($(BR2_arc),y)
+# toolchain __arc__ define conflicts with libosip2 source
+LIBOSIP2_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -U__arc__"
+endif
+
+LIBOSIP2_CONF_OPTS = \
+       --enable-mt=$(if $(BR2_TOOLCHAIN_HAS_THREADS),yes,no)
+
+$(eval $(autotools-package))