The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libnl / libnl.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libnl/libnl.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libnl/libnl.mk
new file mode 100644 (file)
index 0000000..5993e97
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# libnl
+#
+################################################################################
+
+LIBNL_VERSION = 3.2.26
+LIBNL_SITE = https://github.com/thom311/libnl/releases/download/libnl$(subst .,_,$(LIBNL_VERSION))
+LIBNL_LICENSE = LGPLv2.1+
+LIBNL_LICENSE_FILES = COPYING
+LIBNL_INSTALL_STAGING = YES
+LIBNL_DEPENDENCIES = host-bison host-flex
+
+ifeq ($(BR2_PACKAGE_LIBNL_TOOLS),y)
+LIBNL_CONF_OPTS += --enable-cli
+else
+LIBNL_CONF_OPTS += --disable-cli
+endif
+
+$(eval $(autotools-package))