The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libnftnl / libnftnl.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libnftnl/libnftnl.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libnftnl/libnftnl.mk
new file mode 100644 (file)
index 0000000..703bdee
--- /dev/null
@@ -0,0 +1,29 @@
+################################################################################
+#
+# libnftnl
+#
+################################################################################
+
+LIBNFTNL_VERSION = 1.0.3
+LIBNFTNL_SITE = http://netfilter.org/projects/libnftnl/files
+LIBNFTNL_SOURCE = libnftnl-$(LIBNFTNL_VERSION).tar.bz2
+LIBNFTNL_LICENSE = GPLv2+
+LIBNFTNL_LICENSE_FILES = COPYING
+LIBNFTNL_INSTALL_STAGING = YES
+LIBNFTNL_DEPENDENCIES = host-pkgconf libmnl
+
+ifeq ($(BR2_PACKAGE_LIBNFTNL_JSON),y)
+LIBNFTNL_CONF_OPTS += --with-json-parsing
+LIBNFTNL_DEPENDENCIES += jansson
+else
+LIBNFTNL_CONF_OPTS += --without-json-parsing
+endif
+
+ifeq ($(BR2_PACKAGE_LIBNFTNL_XML),y)
+LIBNFTNL_CONF_OPTS += --with-xml-parsing
+LIBNFTNL_DEPENDENCIES += mxml
+else
+LIBNFTNL_CONF_OPTS += --without-xml-parsing
+endif
+
+$(eval $(autotools-package))