The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libnfc / libnfc.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libnfc/libnfc.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libnfc/libnfc.mk
new file mode 100644 (file)
index 0000000..ff55f93
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# libnfc
+#
+################################################################################
+
+LIBNFC_VERSION = 7b7f5061427b5456835dd48923a8cc0563cfd1e9
+LIBNFC_SITE = http://libnfc.googlecode.com/git
+LIBNFC_SITE_METHOD = git
+LIBNFC_LICENSE = LGPLv3+
+LIBNFC_LICENSE_FILES = COPYING
+LIBNFC_AUTORECONF = YES
+LIBNFC_INSTALL_STAGING = YES
+
+LIBNFC_DEPENDENCIES = host-pkgconf libusb libusb-compat
+
+# N.B. The acr122 driver requires pcsc-lite.
+LIBNFC_CONF_OPTS = --with-drivers=arygon,pn53x_usb
+
+ifeq ($(BR2_PACKAGE_LIBNFC_EXAMPLES),y)
+LIBNFC_CONF_OPTS += --enable-example
+LIBNFC_DEPENDENCIES += readline
+else
+LIBNFC_CONF_OPTS += --disable-example
+endif
+
+$(eval $(autotools-package))