The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libmpeg2 / libmpeg2.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libmpeg2/libmpeg2.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libmpeg2/libmpeg2.mk
new file mode 100644 (file)
index 0000000..124c749
--- /dev/null
@@ -0,0 +1,32 @@
+################################################################################
+#
+# libmpeg2
+#
+################################################################################
+
+LIBMPEG2_VERSION = 0.5.1
+LIBMPEG2_SITE = http://libmpeg2.sourceforge.net/files
+LIBMPEG2_LICENSE = GPLv2+
+LIBMPEG2_LICENSE_FILES = COPYING
+LIBMPEG2_INSTALL_STAGING = YES
+LIBMPEG2_AUTORECONF = YES
+LIBMPEG2_CONF_OPTS = --without-x --disable-directx
+
+ifeq ($(BR2_PACKAGE_SDL),y)
+LIBMPEG2_CONF_ENV += ac_cv_prog_SDLCONFIG=$(STAGING_DIR)/usr/bin/sdl-config
+LIBMPEG2_CONF_OPTS += --enable-sdl
+LIBMPEG2_DEPENDENCIES += sdl
+else
+LIBMPEG2_CONF_OPTS += --disable-sdl
+endif
+
+ifneq ($(BR2_PACKAGE_LIBMPEG2_BINS),y)
+define LIBMPEG2_REMOVE_BINS
+       rm -f $(addprefix $(TARGET_DIR)/usr/bin/,\
+               mpeg2dec corrupt_mpeg2 extract_mpeg2)
+endef
+
+LIBMPEG2_POST_INSTALL_TARGET_HOOKS += LIBMPEG2_REMOVE_BINS
+endif
+
+$(eval $(autotools-package))