The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libmicrohttpd / libmicrohttpd.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libmicrohttpd/libmicrohttpd.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libmicrohttpd/libmicrohttpd.mk
new file mode 100644 (file)
index 0000000..e2ff1cf
--- /dev/null
@@ -0,0 +1,24 @@
+################################################################################
+#
+# libmicrohttpd
+#
+################################################################################
+
+LIBMICROHTTPD_VERSION = 0.9.41
+LIBMICROHTTPD_SITE = $(BR2_GNU_MIRROR)/libmicrohttpd
+LIBMICROHTTPD_LICENSE_FILES = COPYING
+LIBMICROHTTPD_INSTALL_STAGING = YES
+LIBMICROHTTPD_CONF_OPTS = --disable-curl --disable-spdy --disable-examples
+
+ifeq ($(BR2_PACKAGE_LIBMICROHTTPD_SSL),y)
+LIBMICROHTTPD_LICENSE = LGPLv2.1+
+LIBMICROHTTPD_DEPENDENCIES += host-pkgconf gnutls libgcrypt
+LIBMICROHTTPD_CONF_ENV += LIBS="$(shell $(PKG_CONFIG_HOST_BINARY) --libs gnutls)"
+LIBMICROHTTPD_CONF_OPTS += --enable-https --with-gnutls=$(STAGING_DIR)/usr \
+       --with-libgcrypt-prefix=$(STAGING_DIR)/usr
+else
+LIBMICROHTTPD_LICENSE = LGPLv2.1+ or eCos
+LIBMICROHTTPD_CONF_OPTS += --disable-https
+endif
+
+$(eval $(autotools-package))