The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / liblockfile / liblockfile.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/liblockfile/liblockfile.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/liblockfile/liblockfile.mk
new file mode 100644 (file)
index 0000000..4f7a67e
--- /dev/null
@@ -0,0 +1,29 @@
+################################################################################
+#
+# liblockfile
+#
+################################################################################
+
+LIBLOCKFILE_VERSION = 1.08
+LIBLOCKFILE_SOURCE = liblockfile_$(LIBLOCKFILE_VERSION).orig.tar.gz
+LIBLOCKFILE_SITE = http://snapshot.debian.org/archive/debian/20141023T043132Z/pool/main/libl/liblockfile
+LIBLOCKFILE_PATCH = liblockfile_$(LIBLOCKFILE_VERSION)-4.debian.tar.bz2
+
+LIBLOCKFILE_LICENSE = LGPLv2+, dotlockfile GPLv2+
+# No license file included, it refers to the gnu.org website
+
+LIBLOCKFILE_INSTALL_STAGING = YES
+LIBLOCKFILE_CONF_OPTS = --mandir=/usr/share/man
+
+define LIBLOCKFILE_INSTALL_STAGING_CMDS
+       mkdir -p $(addprefix $(STAGING_DIR)/usr/share/man/man,1 3)
+       rm -f $(STAGING_DIR)/usr/lib/liblockfile.so
+       $(MAKE) -C $(LIBLOCKFILE_DIR) ROOT=$(STAGING_DIR) install
+       ln -sf liblockfile.so $(STAGING_DIR)/usr/lib/liblockfile.so.1
+endef
+
+define LIBLOCKFILE_INSTALL_TARGET_CMDS
+       cp -a $(STAGING_DIR)/usr/lib/liblockfile.so* $(TARGET_DIR)/usr/lib
+endef
+
+$(eval $(autotools-package))