The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libjpeg / libjpeg.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libjpeg/libjpeg.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libjpeg/libjpeg.mk
new file mode 100644 (file)
index 0000000..c4190c7
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# libjpeg
+#
+################################################################################
+
+LIBJPEG_VERSION = 9a
+LIBJPEG_SITE = http://www.ijg.org/files
+LIBJPEG_SOURCE = jpegsrc.v$(LIBJPEG_VERSION).tar.gz
+LIBJPEG_LICENSE = jpeg-license (BSD-3c-like)
+LIBJPEG_LICENSE_FILES = README
+LIBJPEG_INSTALL_STAGING = YES
+
+define LIBJPEG_REMOVE_USELESS_TOOLS
+       rm -f $(addprefix $(TARGET_DIR)/usr/bin/,cjpeg djpeg jpegtran rdjpgcom wrjpgcom)
+endef
+
+LIBJPEG_POST_INSTALL_TARGET_HOOKS += LIBJPEG_REMOVE_USELESS_TOOLS
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))