The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libiqrf / 0002-use-only-c-language.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libiqrf/0002-use-only-c-language.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/libiqrf/0002-use-only-c-language.patch
new file mode 100644 (file)
index 0000000..2f1c23c
--- /dev/null
@@ -0,0 +1,29 @@
+Use only the C language
+
+libirqf is written completely in C, but by default, CMake assumes that
+both C and C++ are used, and therefore verifies that a C++ compiler is
+installed. This may not necessarily be the case for a C-only package
+in Buildroot.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/src/CMakeLists.txt
+===================================================================
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -1,5 +1,3 @@
+-project(iqrf)
+-
+ set (iqrf_version_major 0)
+ set (iqrf_version_minor 1)
+ set (iqrf_version_patch 2)
+Index: b/CMakeLists.txt
+===================================================================
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,3 +1,5 @@
++project(iqrf C)
++
+ cmake_minimum_required(VERSION 2.8.1)
+ enable_testing()