The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libinput / libinput.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libinput/libinput.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libinput/libinput.mk
new file mode 100644 (file)
index 0000000..bacee6a
--- /dev/null
@@ -0,0 +1,19 @@
+################################################################################
+#
+# libinput
+#
+################################################################################
+
+LIBINPUT_VERSION = 0.14.1
+LIBINPUT_SOURCE = libinput-$(LIBINPUT_VERSION).tar.xz
+LIBINPUT_SITE = http://www.freedesktop.org/software/libinput
+LIBINPUT_LICENSE = MIT
+LIBINPUT_LICENSE_FILES = COPYING
+
+LIBINPUT_DEPENDENCIES = host-pkgconf libevdev mtdev udev
+LIBINPUT_INSTALL_STAGING = YES
+
+# Tests need fork, so just disable them everywhere.
+LIBINPUT_CONF_OPTS = --disable-tests
+
+$(eval $(autotools-package))