The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libhid / libhid.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libhid/libhid.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libhid/libhid.mk
new file mode 100644 (file)
index 0000000..8b3cb2a
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# libhid
+#
+################################################################################
+
+LIBHID_VERSION = 0.2.16
+LIBHID_SITE = http://sources.buildroot.net
+LIBHID_DEPENDENCIES = libusb-compat libusb
+LIBHID_INSTALL_STAGING = YES
+LIBHID_AUTORECONF = YES
+LIBHID_LICENSE = GPLv2
+LIBHID_LICENSE_FILES = COPYING
+# configure runs libusb-config for cflags/ldflags. Ensure it picks up
+# the target version
+LIBHID_CONF_ENV = PATH=$(STAGING_DIR)/usr/bin:$(BR_PATH)
+LIBHID_CONF_OPTS = \
+       --disable-swig \
+       --disable-werror \
+       --without-doxygen \
+       --disable-package-config
+
+$(eval $(autotools-package))