The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libftdi / libftdi.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libftdi/libftdi.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libftdi/libftdi.mk
new file mode 100644 (file)
index 0000000..8370b0a
--- /dev/null
@@ -0,0 +1,24 @@
+################################################################################
+#
+# libftdi
+#
+################################################################################
+
+LIBFTDI_VERSION = 0.20
+LIBFTDI_SITE = http://www.intra2net.com/en/developer/libftdi/download
+LIBFTDI_DEPENDENCIES = libusb-compat libusb
+LIBFTDI_INSTALL_STAGING = YES
+LIBFTDI_CONFIG_SCRIPTS = libftdi-config
+LIBFTDI_AUTORECONF = YES
+
+LIBFDTI_CONF_OPTS = --without-examples
+
+# configure detect it automaticaly so we need to force it
+ifeq ($(BR2_PACKAGE_LIBTFDI_CPP),y)
+LIBFDTI_CONF_OPTS += --enable-libftdipp
+else
+LIBFDTI_CONF_OPTS += --disable-libftdipp
+endif
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))