The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libfribidi / libfribidi.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libfribidi/libfribidi.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libfribidi/libfribidi.mk
new file mode 100644 (file)
index 0000000..12e7664
--- /dev/null
@@ -0,0 +1,24 @@
+################################################################################
+#
+# libfribidi
+#
+################################################################################
+
+LIBFRIBIDI_VERSION = 0.19.6
+LIBFRIBIDI_SOURCE = fribidi-$(LIBFRIBIDI_VERSION).tar.bz2
+LIBFRIBIDI_SITE = http://www.fribidi.org/download
+LIBFRIBIDI_LICENSE = LGPLv2.1+
+LIBFRIBIDI_LICENSE_FILES = COPYING
+LIBFRIBIDI_INSTALL_STAGING = YES
+# Ships a beta libtool version hence our patch doesn't apply.
+# Run autoreconf to regenerate ltmain.sh.
+LIBFRIBIDI_AUTORECONF = YES
+LIBFRIBIDI_DEPENDENCIES = host-pkgconf
+
+ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
+ LIBFRIBIDI_DEPENDENCIES += libglib2
+else
+ LIBFRIBIDI_CONF_OPTS += --with-glib=no
+endif
+
+$(eval $(autotools-package))