The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libfreeimage / 0001-no-root-install.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libfreeimage/0001-no-root-install.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/libfreeimage/0001-no-root-install.patch
new file mode 100644 (file)
index 0000000..54756d8
--- /dev/null
@@ -0,0 +1,20 @@
+Makefile.gnu: allow non-root install by not enforcing root ownserhip
+
+Signed-off-by: Rémi Rérolle <remi.rerolle@gmail.com>
+
+diff -ruN a/Makefile.gnu b/Makefile.gnu
+--- a/Makefile.gnu     2015-04-09 16:34:02.315316841 +0200
++++ b/Makefile.gnu     2015-04-09 16:34:28.875483201 +0200
+@@ -71,9 +71,9 @@
+ install:
+       install -d $(INCDIR) $(INSTALLDIR)
+-      install -m 644 -o root -g root $(HEADER) $(INCDIR)
+-      install -m 644 -o root -g root $(STATICLIB) $(INSTALLDIR)
+-      install -m 755 -o root -g root $(SHAREDLIB) $(INSTALLDIR)
++      install -m 644 $(HEADER) $(INCDIR)
++      install -m 644 $(STATICLIB) $(INSTALLDIR)
++      install -m 755 $(SHAREDLIB) $(INSTALLDIR)
+       ln -sf $(SHAREDLIB) $(INSTALLDIR)/$(VERLIBNAME)
+       ln -sf $(VERLIBNAME) $(INSTALLDIR)/$(LIBNAME)   
+ #     ldconfig