The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libevent / libevent.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libevent/libevent.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libevent/libevent.mk
new file mode 100644 (file)
index 0000000..d67c738
--- /dev/null
@@ -0,0 +1,39 @@
+################################################################################
+#
+# libevent
+#
+################################################################################
+
+LIBEVENT_VERSION_MAJOR = 2.0
+LIBEVENT_VERSION = $(LIBEVENT_VERSION_MAJOR).22-stable
+LIBEVENT_SITE = http://downloads.sourceforge.net/project/levent/libevent/libevent-$(LIBEVENT_VERSION_MAJOR)
+LIBEVENT_INSTALL_STAGING = YES
+LIBEVENT_LICENSE = BSD-3c, OpenBSD
+LIBEVENT_LICENSE_FILES = LICENSE
+# For 0001-Disable-building-test-programs.patch
+LIBEVENT_AUTORECONF = YES
+
+define LIBEVENT_REMOVE_PYSCRIPT
+       rm $(TARGET_DIR)/usr/bin/event_rpcgen.py
+endef
+
+# libevent installs a python script to target - get rid of it if we
+# don't have python support enabled
+ifneq ($(BR2_PACKAGE_PYTHON),y)
+LIBEVENT_POST_INSTALL_TARGET_HOOKS += LIBEVENT_REMOVE_PYSCRIPT
+endif
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+LIBEVENT_DEPENDENCIES += openssl
+LIBEVENT_CONF_OPTS += --enable-openssl
+# openssl needs zlib but configure forgets to link against it causing
+# openssl detection to fail
+ifeq ($(BR2_STATIC_LIBS),y)
+LIBEVENT_CONF_ENV += OPENSSL_LIBADD='-lz'
+endif
+else
+LIBEVENT_CONF_OPTS += --disable-openssl
+endif
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))