The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libev / libev.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libev/libev.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libev/libev.mk
new file mode 100644 (file)
index 0000000..cde2ee0
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# libev
+#
+################################################################################
+
+LIBEV_VERSION = 4.19
+LIBEV_SITE = http://dist.schmorp.de/libev
+LIBEV_INSTALL_STAGING = YES
+LIBEV_LICENSE = BSD-2c or GPLv2+
+LIBEV_LICENSE_FILES = LICENSE
+
+# The 'compatibility' event.h header conflicts with libevent
+# It's completely unnecessary for BR packages so remove it
+define LIBEV_DISABLE_EVENT_H_INSTALL
+       $(SED) 's/ event.h//' $(@D)/Makefile.in
+endef
+LIBEV_POST_PATCH_HOOKS += LIBEV_DISABLE_EVENT_H_INSTALL
+
+$(eval $(autotools-package))