The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libenca / libenca.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libenca/libenca.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libenca/libenca.mk
new file mode 100644 (file)
index 0000000..184cac9
--- /dev/null
@@ -0,0 +1,26 @@
+################################################################################
+#
+# libenca
+#
+################################################################################
+
+LIBENCA_VERSION = 1.16
+LIBENCA_SITE = $(call github,nijel,enca,$(LIBENCA_VERSION))
+LIBENCA_INSTALL_STAGING = YES
+LIBENCA_LICENSE = GPLv2
+LIBENCA_LICENSE_FILES = COPYING
+LIBENCA_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBICONV),libiconv)
+
+LIBENCA_CONF_ENV += \
+       ac_cv_file__dev_random=yes \
+       ac_cv_file__dev_urandom=yes \
+       ac_cv_file__dev_arandom=no \
+       ac_cv_file__dev_srandom=no
+
+define LIBENCA_MAKE_HOST_TOOL
+       $(MAKE) -C $(@D)/tools $(HOST_CONFIGURE_OPTS) make_hash
+endef
+
+LIBENCA_PRE_BUILD_HOOKS += LIBENCA_MAKE_HOST_TOOL
+
+$(eval $(autotools-package))