The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libdvdread / 0001-fix-os2-support.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libdvdread/0001-fix-os2-support.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/libdvdread/0001-fix-os2-support.patch
new file mode 100644 (file)
index 0000000..755bfaf
--- /dev/null
@@ -0,0 +1,31 @@
+configure: fix build on NIOS II platform
+
+NIOS II is a CPU architecture from Altera, which uses 'nios2' as the
+architecture part of the tuple. Unfortunately, 'nios2' matches the
+current '*os2*' test done by libdvdread's configure script to detect
+the OS/2 operating system. This leads to build issues as the build
+process of libdvdread then tries to use OS/2 specific compiler
+options, that do not exist in the gcc used for Linux/NIOS2.
+
+To fix this, this patch makes the test for OS/2 a little bit more
+specific: in the case of the OS/2 operating system, the OS part of the
+tuple contains just 'os2' (confirmed by looking at config.guess and
+config.sub in the gnuconfig project). So using '*-os2-*' will properly
+match the OS/2 operating system but not the NIOS II architecture.
+
+Upstream-status: submitted
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/configure.ac
+===================================================================
+--- a/configure.ac
++++ b/configure.ac
+@@ -146,7 +146,7 @@
+   *cygwin*)
+     LDFLAGS="-no-undefined $LDFLAGS"
+     ;;
+-  *os2*)
++  *-os2-*)
+     LDFLAGS="-no-undefined -Zbin-files $LDFLAGS"
+     ;;
+   *)