The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libdnet / 0002-python-makefile.patch
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libdnet/0002-python-makefile.patch b/cirros-testvm/src-cirros/buildroot-2015.05/package/libdnet/0002-python-makefile.patch
new file mode 100644 (file)
index 0000000..fb41e43
--- /dev/null
@@ -0,0 +1,16 @@
+---
+ python/Makefile.am |    1 +
+ 1 file changed, 1 insertion(+)
+
+Index: libdnet-1.11/python/Makefile.am
+===================================================================
+--- libdnet-1.11.orig/python/Makefile.am
++++ libdnet-1.11/python/Makefile.am
+@@ -11,6 +11,7 @@
+       pyrexc $(srcdir)/dnet.pyx
+ python-build: $(srcdir)/dnet.c
++      CC="$(CC)" LDSHARED="$(CC) -shared" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" $(PYTHON) setup.py build_ext -I$(PYINCDIR) -L$(PYLIBDIR)
+       $(PYTHON) setup.py build
+       touch python-build