The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libcofi / libcofi.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libcofi/libcofi.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libcofi/libcofi.mk
new file mode 100644 (file)
index 0000000..90daff2
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# libcofi
+#
+################################################################################
+
+LIBCOFI_VERSION = 7313fbe12b0593034d0a1b606bf33c7cf4ababce
+LIBCOFI_SITE = $(call github,simonjhall,copies-and-fills,$(LIBCOFI_VERSION))
+LIBCOFI_LICENSE = LGPLv2.1
+LIBCOFI_LICENSE_FILES = README.md
+
+define LIBCOFI_BUILD_CMDS
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define LIBCOFI_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/libcofi_rpi.so $(TARGET_DIR)/usr/lib/libcofi_rpi.so
+endef
+
+$(eval $(generic-package))