The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libcdio / libcdio.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libcdio/libcdio.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libcdio/libcdio.mk
new file mode 100644 (file)
index 0000000..03e6002
--- /dev/null
@@ -0,0 +1,28 @@
+################################################################################
+#
+# libcdio
+#
+################################################################################
+
+LIBCDIO_VERSION = 0.93
+LIBCDIO_SITE = $(BR2_GNU_MIRROR)/libcdio
+LIBCDIO_INSTALL_STAGING = YES
+LIBCDIO_LICENSE = GPLv3+
+LIBCDIO_LICENSE_FILES = COPYING
+LIBCDIO_CONF_OPTS = --disable-example-progs --disable-cddb
+
+ifeq ($(BR2_ENABLE_LOCALE),)
+LIBCDIO_DEPENDENCIES += libiconv
+endif
+
+ifeq ($(BR2_INSTALL_LIBSTDCPP),)
+LIBCDIO_CONF_OPTS += --disable-cxx
+endif
+
+ifeq ($(BR2_PACKAGE_NCURSES),y)
+LIBCDIO_DEPENDENCIES += ncurses
+else
+LIBCDIO_CONF_OPTS += --without-cdda-player
+endif
+
+$(eval $(autotools-package))