The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libatomic_ops / libatomic_ops.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libatomic_ops/libatomic_ops.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libatomic_ops/libatomic_ops.mk
new file mode 100644 (file)
index 0000000..5f698c4
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# libatomic_ops
+#
+################################################################################
+
+LIBATOMIC_OPS_VERSION = libatomic_ops-7_4_2
+LIBATOMIC_OPS_SITE = $(call github,ivmai,libatomic_ops,$(LIBATOMIC_OPS_VERSION))
+LIBATOMIC_OPS_AUTORECONF = YES
+
+# From doc/LICENSING.txt: "Our intent is to make it easy to use
+# libatomic_ops, in both free and proprietary software.  Hence most
+# code that we expect to be linked into a client application is
+# covered by an MIT-style license. A few library routines are covered
+# by the GNU General Public License. These are put into a separate
+# library, libatomic_ops_gpl.a."
+LIBATOMIC_OPS_LICENSE = MIT (main library) / GPLv2+ (gpl extension)
+LIBATOMIC_OPS_LICENSE_FILES = doc/LICENSING.txt COPYING
+
+LIBATOMIC_OPS_INSTALL_STAGING = YES
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))