The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / libao / libao.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/libao/libao.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/libao/libao.mk
new file mode 100644 (file)
index 0000000..a314c08
--- /dev/null
@@ -0,0 +1,34 @@
+################################################################################
+#
+# libao
+#
+################################################################################
+
+LIBAO_VERSION = 1.2.0
+LIBAO_SITE = http://downloads.xiph.org/releases/ao
+LIBAO_DEPENDENCIES = host-pkgconf
+LIBAO_INSTALL_STAGING = YES
+LIBAO_LICENSE = GPLv2+
+LIBAO_LICENSE_FILES = COPYING
+LIBAO_CONF_OPTS = \
+       --disable-esd \
+       --disable-wmm \
+       --disable-arts \
+       --disable-nas \
+       --disable-pulse \
+       --disable-broken-oss
+
+ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
+LIBAO_DEPENDENCIES += alsa-lib
+LIBAO_CONF_OPTS += --enable-alsa --enable-alsa-mmap
+
+# Remove the OSS plugin if ALSA is enabled, as libao will prefer ALSA anyway
+define LIBAO_REMOVE_OSS_PLUGIN
+       rm -f $(TARGET_DIR)/usr/lib/ao/plugins-4/liboss.so
+endef
+LIBAO_POST_INSTALL_TARGET_HOOKS += LIBAO_REMOVE_OSS_PLUGIN
+else
+LIBAO_CONF_OPTS += --disable-alsa
+endif
+
+$(eval $(autotools-package))