The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / lesstif / lesstif.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/lesstif/lesstif.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/lesstif/lesstif.mk
new file mode 100644 (file)
index 0000000..6ce2339
--- /dev/null
@@ -0,0 +1,41 @@
+################################################################################
+#
+# lesstif
+#
+################################################################################
+LESSTIF_VERSION = 0.95.2
+LESSTIF_SOURCE = lesstif-$(LESSTIF_VERSION).tar.bz2
+LESSTIF_SITE = http://downloads.sourceforge.net/project/lesstif/lesstif/$(LESSTIF_VERSION)
+LESSTIF_INSTALL_STAGING = YES
+LESSTIF_DEPENDENCIES = \
+       xlib_libXt \
+       xlib_libXext \
+       freetype
+LESSTIF_LICENSE = LGPLv2+
+LESSTIF_LICENSE_FILES = COPYING.LIB
+LESSTIF_CONF_OPTS = \
+       --with-gnu-ld \
+       --with-freetype-config=$(STAGING_DIR)/usr/bin/freetype-config \
+       --enable-production=yes \
+       --enable-build-tests=no \
+       --no-recursion
+
+# Reduces the buggy makefile to the smallest possible (and working) thing
+define LESSTIF_NOMAN2HTML
+       echo "all:"     > $(@D)/doc/Makefile
+       echo ""                 >> $(@D)/doc/Makefile
+       echo "install:" >> $(@D)/doc/Makefile
+       echo ""                 >> $(@D)/doc/Makefile
+       echo "clean:"   >> $(@D)/doc/Makefile
+endef
+
+# Prevents to copy ac_find_motif.m4 on target, it would else
+# be created at $(TARGET_DIR)/$(TOPDIR)/output/host/usr/share/aclocal/ac_find_motif.m4
+define LESSTIF_FIXACLOCAL
+       sed -i -e "/install-data-am: install-aclocalDATA/d" $(@D)/scripts/autoconf/Makefile
+endef
+
+LESSTIF_POST_CONFIGURE_HOOKS += LESSTIF_NOMAN2HTML
+LESSTIF_POST_CONFIGURE_HOOKS += LESSTIF_FIXACLOCAL
+
+$(eval $(autotools-package))