The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / leafnode2 / leafnode2.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/leafnode2/leafnode2.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/leafnode2/leafnode2.mk
new file mode 100644 (file)
index 0000000..5b9b854
--- /dev/null
@@ -0,0 +1,43 @@
+################################################################################
+#
+# leafnode2
+#
+################################################################################
+
+LEAFNODE2_VERSION = 2.0.0.alpha20140727b
+LEAFNODE2_SOURCE = leafnode-$(LEAFNODE2_VERSION).tar.bz2
+LEAFNODE2_SITE = http://www.dt.e-technik.tu-dortmund.de/~ma/leafnode/beta
+LEAFNODE2_LICENSE = LGPLv2.1
+LEAFNODE2_LICENSE_FILES = COPYING COPYING.LGPL
+LEAFNODE2_DEPENDENCIES = host-pcre pcre
+
+LEAFNODE2_CONF_ENV = \
+       PCRECONFIG="$(STAGING_DIR)/usr/bin/pcre-config"
+
+# --enable-runas-user use 'news' as default but the configure stop
+# if news doesn't exist on the build host.
+# Use 'root' while cross-compiling 
+LEAFNODE2_CONF_OPTS = \
+       --sysconfdir=/etc/leafnode2 \
+       --enable-spooldir=/var/spool/news \
+       --enable-runas-user=root
+
+# Leafnode2 needs the host version of b_sortnl during
+# compilation. Instead of creating a seperate host package and
+# installing b_sortnl to $(HOST_DIR) this binary is compiled
+# on-the-fly, host-pcre is needed for this
+define LEAFNODE2_BUILD_SORTNL_TOOL
+       cd $(@D); \
+       $(HOSTCC) $(HOST_CFLAGS) -o b_sortnl_host \
+               arc4random.c mergesort.c b_sortnl.c critmem_malloc.c \
+               critmem_realloc.c -DHAVE_CONFIG_H -I$(HOST_DIR)/usr/include \
+               -L $(HOST_DIR)/usr/lib -Wl,-rpath,$(HOST_DIR)/usr/lib -lpcre
+endef
+
+LEAFNODE2_PRE_BUILD_HOOKS += LEAFNODE2_BUILD_SORTNL_TOOL
+
+define LEAFNODE2_USERS
+       news -1 news -1 * - - - Leafnode2 daemon
+endef
+
+$(eval $(autotools-package))