The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / lcdproc / lcdproc.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/lcdproc/lcdproc.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/lcdproc/lcdproc.mk
new file mode 100644 (file)
index 0000000..4fbeca1
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# lcdproc
+#
+################################################################################
+
+LCDPROC_VERSION = 0.5.7
+LCDPROC_SITE = http://downloads.sourceforge.net/project/lcdproc/lcdproc/$(LCDPROC_VERSION)
+LCDPROC_LICENSE = GPLv2+
+LCDPROC_LICENSE_FILES = COPYING
+LCDPROC_MAKE = $(MAKE1)
+
+LCDPROC_CONF_OPTS = --enable-drivers=$(BR2_PACKAGE_LCDPROC_DRIVERS) \
+       --with-ft-prefix="$(STAGING_DIR)/usr" \
+       --with-ft-exec-prefix="$(STAGING_DIR)/usr"
+
+ifeq ($(BR2_PACKAGE_LCDPROC_MENUS),y)
+LCDPROC_CONF_OPTS += --enable-lcdproc-menus
+endif
+
+LCDPROC_DEPENDENCIES = freetype ncurses zlib
+
+$(eval $(autotools-package))