The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / lbreakout2 / lbreakout2.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/lbreakout2/lbreakout2.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/lbreakout2/lbreakout2.mk
new file mode 100644 (file)
index 0000000..d72b949
--- /dev/null
@@ -0,0 +1,36 @@
+################################################################################
+#
+# lbreakout2
+#
+################################################################################
+
+LBREAKOUT2_SITE = http://downloads.sourceforge.net/lgames/lbreakout2/2.6
+LBREAKOUT2_VERSION = 2.6.4
+LBREAKOUT2_LICENSE = GPLv2+
+LBREAKOUT2_LICENSE_FILES = COPYING
+
+LBREAKOUT2_DEPENDENCIES = sdl libpng
+
+LBREAKOUT2_CONF_ENV = \
+       SDL_CONFIG="$(STAGING_DIR)/usr/bin/sdl-config"
+
+ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
+LBREAKOUT2_DEPENDENCIES += gettext
+LBREAKOUT2_CONF_ENV += LIBS=-lintl
+endif
+
+ifeq ($(BR2_PACKAGE_LBREAKOUT2_AUDIO),y)
+LBREAKOUT2_DEPENDENCIES += sdl_mixer
+LBREAKOUT2_CONF_OPTS += --enable-audio=yes
+else
+LBREAKOUT2_CONF_OPTS += --disable-audio
+endif
+
+ifeq ($(BR2_PACKAGE_LBREAKOUT2_NET),y)
+LBREAKOUT2_DEPENDENCIES += sdl_net
+LBREAKOUT2_CONF_OPTS += --enable-network=yes
+else
+LBREAKOUT2_CONF_OPTS += --disable-network
+endif
+
+$(eval $(autotools-package))