The cirros image was rebuilt against the 3.13.0-83 kernel, drivers e1000e, igbvf...
[packages/trusty/cirros-testvm.git] / cirros-testvm / src-cirros / buildroot-2015.05 / package / kodi-addon-xvdr / kodi-addon-xvdr.mk
diff --git a/cirros-testvm/src-cirros/buildroot-2015.05/package/kodi-addon-xvdr/kodi-addon-xvdr.mk b/cirros-testvm/src-cirros/buildroot-2015.05/package/kodi-addon-xvdr/kodi-addon-xvdr.mk
new file mode 100644 (file)
index 0000000..e05510c
--- /dev/null
@@ -0,0 +1,26 @@
+################################################################################
+#
+# kodi-addon-xvdr
+#
+################################################################################
+
+# This cset is on master. When a Helix branch is made, we should
+# follow it, as incompatible changes in the plugins API can happen
+# on the master branch.
+KODI_ADDON_XVDR_VERSION = 328fa653b821a4edc1256a13833f30a4483e2819
+KODI_ADDON_XVDR_SITE = $(call github,pipelka,xbmc-addon-xvdr,$(KODI_ADDON_XVDR_VERSION))
+KODI_ADDON_XVDR_LICENSE = GPLv2+
+KODI_ADDON_XVDR_LICENSE_FILES = COPYING
+
+# There's no ./configure in the git tree, we need to generate it
+# kodi-addon-xvdr uses a weird autogen.sh script, which
+# is even incorrect (it's missing the #! ) Sigh... :-(
+# Fortunately, with our little patch, it autoreconfs nicely! :-)
+KODI_ADDON_XVDR_AUTORECONF = YES
+
+# This really is a runtime dependency, but we need KODI to be installed
+# first, since we'll install files in KODI's directories _after_ KODI has
+# installed his own files
+KODI_ADDON_XVDR_DEPENDENCIES = kodi
+
+$(eval $(autotools-package))